Reveal

Need help with an engine or coding not on the list? Need help with a game or the website and forums here? Direct all questions here.

Re: Reveal

Postby KyleMassacre » Fri Dec 04, 2015 7:15 am

Is that more of what you are looking for? It didnt print out the column names that my code told it to but i am just worried about the `sect_id`. Is that supposed to be NULL? If thats not a problem you can now loop through that array with like a foreach() or you can put in a where clause in your query to only look for that sector_id
Skype: KyleMassacre
My NWE Modules
User avatar
KyleMassacre
 
Posts: 567
Joined: Wed Nov 27, 2013 7:42 am
Has thanked: 19 times
Been thanked: 36 times

Re: Reveal

Postby SpiritWebb » Fri Dec 04, 2015 10:12 am

KyleMassacre wrote:Is that more of what you are looking for? It didnt print out the column names that my code told it to but i am just worried about the `sect_id`. Is that supposed to be NULL? If thats not a problem you can now loop through that array with like a foreach() or you can put in a where clause in your query to only look for that sector_id


It's not supposed to be null, and in fact in the database, there are no empty rows at all. It only inserts when the player enters that sector for the first time.
Image

Image
User avatar
SpiritWebb
Rockywood Studios
 
Posts: 3092
Joined: Sun Jul 12, 2009 6:25 pm
Location: Little Rock, AR
Has thanked: 6 times
Been thanked: 11 times
Blog: View Blog (2)

Re: Reveal

Postby SpiritWebb » Fri Dec 04, 2015 10:17 am

Here is the explored_univ db

explored_univ_db.png
explored_univ_db.png (32.95 KiB) Viewed 481 times
Image

Image
User avatar
SpiritWebb
Rockywood Studios
 
Posts: 3092
Joined: Sun Jul 12, 2009 6:25 pm
Location: Little Rock, AR
Has thanked: 6 times
Been thanked: 11 times
Blog: View Blog (2)

Re: Reveal

Postby KyleMassacre » Fri Dec 04, 2015 11:39 am

Something isn't right. Did you change any of the code I pasted for you to try out? It's not printing the array keys that I posted
Skype: KyleMassacre
My NWE Modules
User avatar
KyleMassacre
 
Posts: 567
Joined: Wed Nov 27, 2013 7:42 am
Has thanked: 19 times
Been thanked: 36 times

Re: Reveal

Postby SpiritWebb » Fri Dec 04, 2015 12:19 pm

KyleMassacre wrote:Something isn't right. Did you change any of the code I pasted for you to try out? It's not printing the array keys that I posted


Nope did it verbatim as you asked, never changed any code you pasted.
Image

Image
User avatar
SpiritWebb
Rockywood Studios
 
Posts: 3092
Joined: Sun Jul 12, 2009 6:25 pm
Location: Little Rock, AR
Has thanked: 6 times
Been thanked: 11 times
Blog: View Blog (2)

Re: Reveal

Postby KyleMassacre » Sat Dec 05, 2015 1:06 pm

Something isn't right though. It's not returning the correct array
Skype: KyleMassacre
My NWE Modules
User avatar
KyleMassacre
 
Posts: 567
Joined: Wed Nov 27, 2013 7:42 am
Has thanked: 19 times
Been thanked: 36 times

Re: Reveal

Postby SpiritWebb » Sat Dec 05, 2015 1:48 pm

KyleMassacre wrote:Something isn't right though. It's not returning the correct array


I know, this has been my issue. I know another way I could do it, but I am not putting in 1002 columns into the DB
Image

Image
User avatar
SpiritWebb
Rockywood Studios
 
Posts: 3092
Joined: Sun Jul 12, 2009 6:25 pm
Location: Little Rock, AR
Has thanked: 6 times
Been thanked: 11 times
Blog: View Blog (2)

Previous

Return to Advanced Help and Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron

x